The Amazon Web Services (AWS) outage that began on October 20 has been fully resolved. All systems and services that rely on AWS infrastructure continue to operate normally, and no further disruptions have been observed.
After more than a full day of active monitoring and stable performance across all affected systems, Information Technology has closed this incident. Our team will continue routine oversight of critical campus and third-party services as part of standard operations.
If you experience any lingering issues, please contact TechServices at 978.934.4357, and our staff will assist you promptly.
Thank you again for your patience and cooperation during this event.
Posted Oct 22, 2025 - 10:41 EDT
Monitoring
Amazon Web Services (AWS) has reported full service restoration following today’s widespread outage. At this time, all applications and services from our technology providers that rely on AWS infrastructure appear to be available and operating normally. Some minor performance variations may persist as systems complete recovery and load balancing stabilizes across providers.
Information Technology has transitioned this incident to Monitoring status. Our team will continue to closely observe critical campus systems and third-party services to ensure sustained stability through the late evening and into tomorrow. If conditions remain stable, we will close this event at 5:00 PM EDT on Tuesday, October 21, 2025.
If you continue to experience issues, please contact TechServices at 978-934-4357. Our team will assist you as quickly as possible.
Thank you for your patience and understanding throughout today’s event.
Posted Oct 20, 2025 - 19:18 EDT
Update
At this time, Amazon Web Services (AWS) continues a slow recovery process. An increasing number of Amazon services are returning to operational status. The downstream implication of this is that applications in use at UMass Lowell may start to appear more responsive in the coming hours.
However, it is expected that multiple services will continue to have high error rates into the evening.
Information Technology is continuing to monitor the situation, and will update this space again at 9:00 PM EST on October 20, or earlier if the situation changes substantially. Thank you for your patience.
Posted Oct 20, 2025 - 17:46 EDT
Update
While the situation with Amazon Web Services (AWS) remains fluid and is changing rapidly, it appears that availability is starting to improve. While many applications are still impacted, it appears that some are returning to functionality.
Information Technology is continuing to monitor the situation, and will update this space again at 6:00 PM EST on October 20, or earlier if the situation changes substantially. Thank you for your patience.
Posted Oct 20, 2025 - 15:38 EDT
Update
According to an update at 2:22 PM EDT, Amazon Web Services (AWS) appears to be making progress with service recovery. Reports from users across campus suggest that some applications are less impacted than earlier in the day, though which applications are impacted appears to be fluctuating quickly. AWS appears to be updating service status every half hour to 45 minutes. Those interested may review these updates at: https://health.aws.amazon.com/health/status
Information Technology is continuing to monitor the situation, and will update this space again at 4:00 PM EST on October 20, or if the situation changes substantially. Thank you for your patience.
Posted Oct 20, 2025 - 14:27 EDT
Update
Amazon Web Services (AWS) continues to experience performance issues that impact a wide array of applications on campus and around the world. Initial reports of service availability have been contradicted by later reports of continued service degradation.
Information Technology is continuing to monitor the situation, and will update this space again at 3:00 PM EST on October 20, or if the situation changes substantially. Thank you for your patience.
Posted Oct 20, 2025 - 13:32 EDT
Update
Amazon Web Services (AWS) has reported that they have made some significant progress in stabilizing their services. However, some applications that rely on AWS infrastructure are still reporting degraded or offline services. At this time there is no known workaround for impacted applications.
Information Technology is continuing to monitor the situation, and will update this space again at noon EST on October 20, or if the situation changes substantially. Thank you for your patience.
Posted Oct 20, 2025 - 08:55 EDT
Identified
Information Technology is aware of a major Amazon Web Services (AWS) outage that is impacting many services and software hosted out of their US East Coast region.
Please note that services indicated in this posting are not comprehensive and widespread issues are expected.
While UMass Lowell is not directly an AWS customer, many services we are customers of use AWS, and therefore are degraded.
This outage is being covered by the national news, and we are monitoring though various channels including some of the vendors listed in this incident.
Our next update will be at noon on October 20 or if the situation changes substantially. Thank you for your patience.
Posted Oct 20, 2025 - 05:52 EDT
This incident affected: ERP / Line of Business Software (Salesforce, DocuSign, Slate, ChatGPT, General Backend Services), Connectivity (Campus Internet, Call Center), Academic Technology (Canvas, Blackboard, Echo360 (Lecture Capture), Zoom), Authentication and Security (Duo Multifactor Authentication), and Collaboration Tools (List Server).