Multiple applications unavailable
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 12:43 EDT
Monitoring
At this time, we believe that all applications are back online and operational. It is possible or likely that some performance issues may persist for the rest of the day. If you are unable to access any applications, please contact TechServices at 978.934.4357 and one of our friendly technicians will be happy to help you.

Please note that outages may still be impacting other campuses and/or companies, so if a single (non-UML) website is unavailable, please contact the provider of that website.

Thank you for your patience as we continue to monitor the situation throughout today and the weekend.
Posted Jul 19, 2024 - 14:41 EDT
Update
All affected Web Services applications, including myUML, are operational. Additional updates will be provided as events warrant.
Posted Jul 19, 2024 - 08:42 EDT
Update
At this time, Blackboard is back up and operational. Email, Teams, and other Microsoft 365 components are experiencing intermittent issues including slow response times. Information Technology continues to monitor the situation and is actively working to implement workarounds to this global IT outage as they become available.

Affected Web Services applications include:

myUML (formerly Now/Student Dashboard)
Academic Success Alerts
Attendance
Blackboard Course Management (excludes Blackboard LMS)
Blackboard Feed (excludes Blackboard LMS)
Canvas Feed (excludes Canvas LMS)
Computer Ordering
Course Master
Lecture Capture Requests
River Hawk Experience Distinction
UCAPS Photo Uploads
Posted Jul 19, 2024 - 08:32 EDT
Update
At this time, Blackboard is back up and operational. Email, Teams, and other Microsoft 365 components are experiencing intermittent issues including slow response times. Information Technology continues to monitor the situation and is actively working to implement workarounds to this global IT outage as they become available.
Posted Jul 19, 2024 - 08:31 EDT
Identified
Multiple applications are partially or completely unavailable as of 7/19 1:20 AM EDT. We have identified the cause and are working with our partners to resolve the issue. Updates will be provided as events warrant.

Affected Web Services applications include:

myUML (formerly Now/Student Dashboard)
Academic Success Alerts
Attendance
Blackboard Course Management (excludes Blackboard LMS)
Blackboard Feed (excludes Blackboard LMS)
Canvas Feed (excludes Canvas LMS)
Computer Ordering
Course Master
Lecture Capture Requests
River Hawk Experience Distinction
UCAPS Photo Uploads
Posted Jul 19, 2024 - 02:22 EDT
This incident affected: Collaboration Tools (Email, Microsoft Teams, OneDrive), Web Services (myUML (formerly Now/Student Dashboard), Internal Applications), and Authentication and Security (Microsoft Entra single sign-on (SSO), Active Directory).