Student Network DNS Issues

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Jul 25, 2026 - 09:22 EDT

Monitoring

At this time, Information Technology believes the issues with Student Network DNS resolution are resolved. IT staff will continue to actively monitor the situation to ensure system availability. If you are still experiencing issues accessing websites or online services while connected to the Student Network, please contact TechServices at 978.934.4357 to report the issue to our team. Thank you for your patience, and we apologize for any inconvenience.
Posted Jul 24, 2026 - 17:07 EDT

Investigating

Information Technology is investigating reports of DNS resolution issues on the Student Network. Some users may be unable to access websites and online services while connected to the Student Network. We will update this incident with further details as they become available. We apologize for any inconvenience.
Posted Jul 24, 2026 - 16:27 EDT
This incident affected: Connectivity (DNS).