Contact Center Service Degredation
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted May 01, 2024 - 09:17 EDT
Monitoring
Our solution provider has implemented a fix and all call center calls are working properly at this time. We will continue to work our provider and monitor services to ensure continued operations.
Posted Apr 30, 2024 - 15:43 EDT
Update
Our solution provider continues to work on this high-priority call center telephony issue. An update will be provided by 3:00pm or sooner if there is more information available.
Posted Apr 30, 2024 - 13:49 EDT
Investigating
Information Technology is aware of an issue impacting the University's call centers (GPS, Solution Center, and IT) that not all calls are going through. We are investigating the cause, and are in contact with the solution provider.

Normal calls into or out of the university are not impacted at this time.
Posted Apr 30, 2024 - 12:16 EDT
This incident affected: Connectivity (Telephony).