Comcast is actively working to resolve this issue, but UMass Lowell's Xfinity On Campus services remain offline at this time. An update will be provided here at noon or sooner if more information is available.
Posted Apr 02, 2026 - 09:09 EDT
Identified
Comcast continues to investigate this issue, but UMass Lowell's Xfinity On Campus services remain offline at this time. An update will be provided here tomorrow at 8:00am or sooner if more information is available.
Posted Apr 01, 2026 - 19:06 EDT
Update
Comcast continues to investigate this issue, but the Xfinity On Campus services remain offline at this time. An update will be provided here at 7:00pm or sooner if more information is available.
Posted Apr 01, 2026 - 15:54 EDT
Update
Comcast continues to investigate this issue, but the Xfinity On Campus services remain offline at this time. An update will be provided here at 3:00pm or sooner if more information is available.
Posted Apr 01, 2026 - 12:04 EDT
Investigating
Due to a network issue within Comcast, all UMass Lowell Xfinity On Campus services are offline until Comcast resolves this issue. An update will be provided here at 11:00am or sooner if more information is available.