System Performance Issues

Incident Report for UMass Lowell

Monitoring

UMass Lowell IT, in coordination with our vendor partners, has resolved the issue impacting back-end services. All affected systems are now operating normally. We will continue to monitor to ensure continued stability.
Next update will be provided here if new information becomes available.
Posted Jul 03, 2025 - 03:23 EDT

Identified

UMass Lowell IT continues to troubleshoot the issue with our vendors. The next update will be at 6am, or sooner if new information is available.
Posted Jul 02, 2025 - 23:05 EDT

Update

UMass Lowell IT continues to work with our vendor's engineers to resolve the issue. An update will be provided here by 10pm, or sooner if more information is available.
Posted Jul 02, 2025 - 20:07 EDT

Investigating

IT is aware of system performance issues impacting a variety of back-end services. We are actively investigating with our vendors at this time, and an update will be posted here by 8:00pm or sooner if there new information available.
Posted Jul 02, 2025 - 18:36 EDT
This incident affects: ERP / Line of Business Software (General Backend Services).