Document Imaging Outage

Incident Report for UMass Lowell

Resolved

The Document Imaging service is functioning normally and is fully accessible. UMass Lowell Information Technology will continue to monitor those services to ensure their availability. If you have any questions, please contact UMass Lowell Tech Services at 978-934-4357.
Posted Sep 23, 2025 - 14:58 EDT

Investigating

The Document Imaging service is currently unavailable. An update will be provided by here by 3:30pm, or earlier if additional information is available before that time.
Posted Sep 23, 2025 - 14:10 EDT
This incident affected: ERP / Line of Business Software (General Backend Services).