Intermittent Access to Perceptive Content

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted May 07, 2026 - 13:18 EDT

Investigating

Perceptive Content is currently experiencing intermittent access issues. Some users may be unable to log in at this time. This service is managed by UITS, and they are investigating the issue.

We will provide the next update by 5:00 PM ET today, or sooner if more information becomes available. We apologize for the disruption and appreciate your patience.
Posted May 07, 2026 - 11:44 EDT
This incident affected: ERP / Line of Business Software (Document Management (Softdocs/Etrieve)).