Document Imaging Partial Outage

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 13:09 EDT

Investigating

The Document Imaging/PeopleSoft integration is currently experiencing issues. UITS is aware of the issue and is actively working on a resolution. An update will be provided by here by 4:30pm, or earlier if additional information is available before that time.
Posted Aug 20, 2025 - 14:25 EDT
This incident affected: ERP / Line of Business Software (PeopleSoft Applications).