DUO outage
Incident Report for UMass Lowell
Resolved
At this time all issues with Duo appear to be resolved. If you have any issues with multifactor authentication, please contact TechServices at 978.934.4537 and we will be happy to assist you. Have a great start to your semester!
Posted Sep 06, 2023 - 14:20 EDT
Update
The issue causing Duo authentication failures has been fully resolved by the vendor. All Duo prompt authentications are working as expected. IT will continue to monitor the system to ensure full functionality.
Posted Aug 22, 2023 - 09:34 EDT
Update
Duo authentication prompts are working in most cases - if you experience an issue with a Duo prompt, try again in a few minutes. An update will be posted here when we have more information from the vendor.
Posted Aug 21, 2023 - 15:27 EDT
Monitoring
Update: The vendor has implemented a fix and it appears that Duo prompts are working in some (but not all) cases. If you continue to experience an issue with a Duo prompt, try again in a few minutes. An update will be posted here by 3:30pm.
Posted Aug 21, 2023 - 14:03 EDT
Update
The vendor is continuing to work towards a resolution for these errors. An update will be posted here by 2:00pm.
Posted Aug 21, 2023 - 12:45 EDT
Update
The vendor is continuing to work on a fix for the slowness and failure to load the Duo Prompt. An update will be posted here by 12:30pm.
Posted Aug 21, 2023 - 11:18 EDT
Identified
Update: The vendor has identified the issue causing authentication slowness and failures to load the Duo Prompt and are working toward resolution. An update will be posted here by 11:15am.
Posted Aug 21, 2023 - 10:17 EDT
Investigating
We are aware of an outage with the the DUO multi-factor system. The vendor is aware of the issue and they are investigating. An update will be posted here by 10:30am.
Posted Aug 21, 2023 - 09:41 EDT
This incident affected: Authentication and Security (Duo Multifactor Authentication).