Multiple applications degraded

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 19:34 EDT

Identified

The issue has been identified and temporarily mitigated. Digital Experience apps and services are no longer affected as of 7:10pm EDT.
Posted Sep 16, 2025 - 19:16 EDT

Investigating

Users may experience intermittent errors when using Digital Experience apps and services, including myUML. This issue was reported at approximately 5:05pm EDT. We are investigating this issue and will provide updates as events warrant.
Posted Sep 16, 2025 - 18:53 EDT
This incident affected: Digital Experience (myUML (formerly Now/Student Dashboard), DX API, DX Apps, DX Single Sign-On).