Olsen Hall Partial Electrical Outage

Incident Report for UMass Lowell

Resolved

Facilities is continuing to work on restoring electrical service to Olsen Hall. This status page incident has been closed - please continue to look for campus communication about the restoration of services and reopening of Olsen Hall.
Posted Feb 03, 2026 - 15:09 EST

Update

9:15am: Facilities will be shutting down power to Olsen Hall for several hours this morning to assess and hopefully resolve the electrical issue. All generators will be functional during this time, so some core network/voice services will remain functional but floor-level services will go down during this power outage. An update will be posted here at 11:30am or earlier if more information is available.
Posted Feb 03, 2026 - 09:32 EST

Investigating

Olsen Hall has experienced a partial loss of electrical service, which is affecting power to many classrooms and other parts of the building. Network and voice service in the building are working normally with some minor exceptions. Facilities is actively assessing the electrical situation and the Registrar is emailing students who were scheduled for classes in Olsen this morning.

Information Technology will continue to monitor services and will provide an update here by 10am or sooner if more information is available.
Posted Feb 03, 2026 - 08:55 EST