Potential impact to Wi-Fi services

Incident Report for UMass Lowell

Resolved

All Wi-Fi services are stable and working normally.
Posted Feb 19, 2026 - 07:36 EST

Update

Wi-Fi services continue to be stable and functioning normally at this time. Information Technology will continue to monitor all services and will post an update here by 8:30am, or earlier if anything changes.
Posted Feb 18, 2026 - 20:23 EST

Monitoring

Wi-Fi services are working normally at this time, and Information Technology will continue to monitor all services.
Posted Feb 18, 2026 - 18:08 EST

Investigating

Information Technology is actively investigating a Wi-Fi issue on campus which may cause degraded Wi-Fi performance. An update will be provided here by 6:00pm, or earlier if more information is available.
Posted Feb 18, 2026 - 16:40 EST
This incident affected: Connectivity (Wi-Fi).