Some users may be unable to access Outlook on the web

Incident Report for UMass Lowell

Resolved

Microsoft has confirmed that the issue affecting access to Outlook on the web has been fully resolved. The problem was caused by a recent configuration change that introduced a code regression, impacting users routed through the affected infrastructure. Microsoft has reverted the change and verified the fix through service telemetry and customer confirmation.

The incident began at 12:51 PM EDT and was resolved at 2:55 PM EDT.

Microsoft is assessing their monitoring and detection processes to prevent similar issues in the future.

If you continue to experience any issues, please reach out. Thank you for your patience while Microsoft worked to restore service.
Posted Mar 20, 2025 - 09:00 EDT

Identified

Microsoft has identified an issue causing some users to be unable to access Outlook on the web, receiving a "Something went wrong" error message.

According to Microsoft, they have identified a portion of code that is causing the issue and are working to revert a recent change while analyzing data to determine any further steps.

We will continue to monitor Microsoft's updates and provide further information as it becomes available.

Thank you for your patience.
Posted Mar 19, 2025 - 14:59 EDT
This incident affected: Collaboration Tools (Email).