Wi-Fi Connectivity

Incident Report for UMass Lowell

Monitoring

The campus Wi-Fi issue has been resolved. IT will continue to monitor all services to ensure their continued availability. If you have any Wi-Fi issues, please contact Tech Services.
Posted Nov 22, 2025 - 20:24 EST

Update

As of 4:30 PM, UMass Lowell IT continues to troubleshoot the campus Wi-Fi issue and we have engaged our Wi-Fi vendor in the investigation. Our next update will be at 7 PM or when services are restored, whichever is sooner.
Posted Nov 22, 2025 - 16:41 EST

Investigating

IT is aware of possible Wi-Fi connectivity issues across campus this afternoon. We are actively investigating and our next update will be at 5:00pm, unless the status changes.
Posted Nov 22, 2025 - 15:09 EST
This incident affects: Connectivity (Wi-Fi).