Phone outage
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Mar 23, 2024 - 13:11 EDT
Monitoring
As of 12:30pm, all phone service has been restored. IT will continue to actively monitor these services to ensure continued reliability.
Posted Mar 22, 2024 - 13:53 EDT
Investigating
We are seeing intermittent outages with University phone service. Internal calls within the university are working properly, but we are having sporadic outages with inbound and outbound calls. We are investigating internally and with our carrier. This page will be updated when we have more information.
Posted Mar 22, 2024 - 12:13 EDT
This incident affected: Connectivity (Telephony).