UMass President's Office Firewall Maintenance - Multiple Applications

Incident Report for UMass Lowell

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 08:09 EDT

Monitoring

The UMass President's Office firewall maintenance has been completed and all systems are working as expected. UMass Lowell IT will continue to monitor these systems to ensure their availability.
Posted Sep 28, 2025 - 18:03 EDT

Update

The UMass President's Office firewall maintenance has been extended to 6:00pm today. An update will be provided here by 6:00pm.
Posted Sep 28, 2025 - 17:02 EDT

Investigating

The UMass President's Office firewall maintenance has been extended to 5:00pm today. Access to the SiS, HR, Finance, and Document Imaging systems may be impacted by this firewall maintenance. Another update will be provided here by 5:00pm.
Posted Sep 28, 2025 - 16:34 EDT
This incident affected: ERP / Line of Business Software (PeopleSoft Applications).