Pages on www.uml.edu may not be loading properly

Incident Report for UMass Lowell

Resolved

This incident has been resolved. All pages on www.uml.edu and applications within www.uml.edu/service should be loading normally for all users.

Microsoft mitigated this issue at 3:40pm EDT on 6/12/2025 by disabling the Newark, NJ (EWR) point-of-presence (PoP) for all customers. This issue was isolated to traffic routed to this specific PoP.
Posted Jun 13, 2025 - 16:00 EDT

Monitoring

Microsoft has mitigated this issue as of 3:40pm EDT.
Posted Jun 12, 2025 - 19:52 EDT

Identified

Pages on www.uml.edu, including applications within www.uml.edu/service, may not be loading properly. This issue started at approximately 8:50am EDT on 6/12/2025.

There is a problem with a Microsoft content delivery service responsible for serving resources on these pages. We are working with Microsoft to resolve this issue.
Posted Jun 12, 2025 - 12:18 EDT
This incident affected: Digital Experience (www.uml.edu, DX Apps, DX Single Sign-On).