Email delivery issues

Incident Report for UMass Lowell

Resolved

This issue has been resolved.
Posted Jul 15, 2025 - 11:42 EDT

Monitoring

Our vendor has indicated that email delivery has returned to normal. UMass Lowell IT will continue to monitor these services for continued availability.
Posted Jul 14, 2025 - 13:48 EDT

Investigating

Email inbound or outbound to/from UMass Lowell and other organizations is currently queuing and not being delivered due to an issue at our email security vendor. Internal email between Internal UMass Lowell email is unaffected. The vendor is troubleshooting but no estimated resolution time has been provided yet. The next update will be at 1:30 pm or if the status changes.
Posted Jul 14, 2025 - 11:38 EDT
This incident affected: Collaboration Tools (Email).