Degraded external phone service
Incident Report for UMass Lowell
Resolved
This incident has been resolved.
Posted Jan 30, 2023 - 17:58 EST
Monitoring
This issue has been resolved - IT will continue to monitor the situation.
Posted Jan 30, 2023 - 14:34 EST
Investigating
We are experiencing an issue placing and receiving external phone calls in Teams. It appears to be an issue with Microsoft and we are investigating.
Posted Jan 30, 2023 - 13:51 EST
This incident affected: Connectivity (Telephony).